Configurar escáner Genius ColorPage-Vivid 1200XE en Ubuntu 12.04

Hoy he necesitado escanear un par de documentos y he comprobado que Ubuntu tiene una aplicación llamada Simple Scan que es muy sencillita. He probado con el comando lsusb para comprobar que lo detectaba:

$ lsusb
Bus 007 Device 004: ID 0458:201f KYE Systems Corp. (Mouse Systems) ColorPage-Vivid 1200 XE

Lo detecta perfectamente.

Luego he probado a ejecutar la herramienta scanimage y me da el siguiente error:

$ scanimage
[gt68xx] Couldn’t open firmware file (`/usr/share/sane/gt68xx/CCD569.fw’): Permission denied
scanimage: open of device gt68xx:libusb:007:004 failed: Invalid argument

Buscando… veo que hay que copiar el archivo CCD569.fw a ese directorio. Pero, ¿de dónde saco ese archivo? Aprovechando que lo tenía instalado en Windows 7, lo encuentro en C:\Program Files\ScannerU\CCD569.fw. Lo copio en el directorio anterior y a escanear!

$ sudo mkdir -p /usr/share/sane/gt68xx
$ sudo cp /media/windows/Program\ Files/ScannerU/CCD569.fw /usr/share/sane/gt68xx
$ sudo chmod 666 /usr/share/sane/gt68xx/CCD569.fw
$ scanimage
scanimage: output is not a file, exiting

Ahora el mensaje que da es informativo, pero no de error, así que ejecutamos de nuevo la aplicación Simple Scan y ya podemos escanear nuestros documentos.

 

NOTA: Os pongo aquí el enlace al archivo CCD569.fw por si os hiciera falta. Por limitaciones de WordPress, lo he subido con extensión PDF, así que renombradlo a CCD569.fw.

Instalar Firefox 3.6 en Ubuntu 9.10

Acaba de publicarse la última versión de Firefox 3.6. Ésta aún no está en los repositorios oficiales de Ubuntu. Así que para los impacientes como yo, hay dos alternativas para instalarla:

La primera alternativa es descargarlo desde los servidores de Mozilla, descomprimirlo en el directorio /opt/ y crear un enlace simbólico en el directorio /usr/local/bin/:

cd ~
wget http://download.mozilla.org/?product=firefox-3.6&os=linux&lang=es-ES
sudo tar -C /opt/ -xf ~/firefox-3.6.tar.bz2
sudo ln -s /opt/firefox/firefox /usr/local/bin/firefox

Tras esto, bastará que cerremos y volvamos a iniciar nuestro navegador para que se ejecute esta nueva versión.

La segunda alternativa sería añadir mozillateam/firefox-stable a nuestros repositorios e instalarlo con aptitude:


sudo add-apt-repository ppa:mozillateam/firefox-stable
sudo aptitude update
sudo aptitude full-upgrade

Luego, os recomiendo que vayáis a esta web si queréis instalar el xpi con vuestro idioma, ya que por defecto se instala en inglés.

Por cierto, podéis ver las novedades de esta nueva versión, entre las que destaca el nuevo motor Gecko 1.9.2, mejora de rendimiento en JavaScript y soporte para nuevos atributos CSS y nuevas especificaciones DOM y HTML5.